Animation of falling notes is not smooth - 10.8

Trouble with Synthesia, your keyboard, or adapter? Think you found a bug?
When describing problems, always mention your OS and game version (shown at the bottom of the title screen).

If your keyboard has USB or MIDI ports, there is a tremendously high chance (>99%) it will work with Synthesia. See what you'll need on the keyboards page.
Post Reply
longiner
Posts: 4

Post by longiner »

Hello.
I have experienced the following problem with the newest version of Synthesia (10.8) on Windows 10 platform.
Animation of falling notes and Synthesia play was choppy with multiple breaks for about 100 - 300 ms.
It wasn't problem with MIDI or an virtual instrument. The problem still exist when only Synthesia is running without the instrument.
I've reinstalled Synthesia, without success. Then I've downgraded to version 10.7.5567 and the problem was solved. Animation and play is smooth again. This could be a bug in the newest version of Synthesia I think.
Nicholas
Posts: 13171

Post by Nicholas »

Hmm, strange. There were three changes in 10.8 that had to do with removing the kind of jitter you're seeing. :?

One of them can't be disabled, but the other two can. If you could give this a try, it would be helpful in narrowing the problem down:

1. While launching Synthesia 10.8, hold your Shift key, which should open the configuration window instead of the app.

2. The "System.LimitThreadAffinity" and "System.ElevatePriority" options should both be near the bottom of the list. Try disabling both of them by selecting each from the list and removing the check mark from the Value box.

3. After that, close the configuration window and start Synthesia 10.8 normally.

Does the problem still happen? If it's gone, you could try disabling just one of them at a time to narrow down which of the two is causing the problem. It would be very interested to hear the results!
longiner
Posts: 4

Post by longiner »

Hello Nicholas.

I've just tested these 2 options. It seems to be a problem with "System.LimitThreadAffinity". After disabling this option the problem is gone. Smoothness is still not perfect, but the same as in Synthesia 10.7.5567.

My setup is:
MS WIndows 10 Pro
Core i7 8700K 3,70 GHz
MB: Asus PRIME Z370-A
RAM: 16 GB
RTX 2070
Screen 1 (Which Synthesia is running on): Samsung C49RG9x 5120 x 1440 120Hz (119,970)
Screen 2: NEC EA245WMi 1200 x 1920 60 Hz (59,950).

I hope it can help you with solving this issue.
Nicholas
Posts: 13171

Post by Nicholas »

Interesting. On an i7-8700K, I wouldn't have expected a problem like that.

The thread affinity option was an experiment to begin with (following Microsoft's advice from point #4 in this article) and yours is the first feedback (good or bad) that I've heard about it. If it is causing trouble on a machine as high-end as yours, I think I'll just change it to disabled by default until I get a better chance to test its effects.

Thanks for the follow-up!
Rumsey
Posts: 9

Post by Rumsey »

Hi Longiner,
I'm also getting jerky falling notes with 10.8 on Windows 11. Pleas can you explain how to disable System.LimitThreadAffinity?
Thanks, Simon
Nicholas
Posts: 13171

Post by Nicholas »

The instructions are in the 2nd post down near the top of this page. (It's the one with the numbered list.)
Rumsey
Posts: 9

Post by Rumsey »

Thanks Nicholas, I've also written to you elsewhere on forum regarding 10.9 bug I've found.
paronym
Posts: 27

Post by paronym »

I have a different perspective to offer concerning the setting "System.LimitThreadAffinity".

I've just built a new PC after using an ancient PC for many years (which still ran Synthesia smoothly). My new PC has a 14-core i5 13500 CPU (6 Performance cores, 8 Efficient cores), 64GB DDR5, NVMe SSD, etc.

After installing Synthesia 10.9.5890 on a fresh Windows 11 setup, I found that when playing the built-in songs, there was a lot of stuttering with the falling notes. I remembered reading this thread, so I decided to see whether the System.LimitThreadAffinity setting would make any difference.

After enabling that setting, performance is smooth. And after putting it back to the default (i.e. off) the stuttering comes back. So on my system, I definitely have to have that setting enabled.

Hope this helps. I wonder if it has something to do with having so many CPU cores, and the fact that there is a mixture of performance cores and efficient cores.
Post Reply